Frontline Education Down

Incident Report for Life School

Resolved

This incident has been resolved.
Posted Sep 11, 2026 - 08:09 CDT

Monitoring

A fix has been implemented and we are monitoring the results
Posted Sep 10, 2026 - 14:55 CDT

Identified

Frontline has identified the issue and is currently in the process of resolving it.
Posted Sep 10, 2026 - 14:48 CDT

Investigating

We are currently investigating an issue with logging into Frontline
Posted Sep 10, 2026 - 14:28 CDT
This incident affected: Frontline Education ERP/SIS.