Life School Network - Down

Incident Report for Life School

Resolved

This incident has been resolved.
Posted Apr 25, 2025 - 15:34 CDT

Identified

The Life School network is currently down. This affects all campuses. Our Internet Service Provider is experiencing an issue with their circuits after a failed maintenance window. We are working with them now to get this resolved as quickly as possible.

Thanks,
Posted Apr 25, 2025 - 08:26 CDT
This incident affected: District Network (Red Oak Elementary, Life High School Waxahachie, Life Middle School Waxahachie, Central Office, Lancaster Elementary, Oak Cliff Elementary, Oak Cliff Secondary, Mountain Creek Elementary, Cedar Hill Elementary, Carrollton Elementary).