Lifeschool Classlink Outage !!! Amazon AWS issue.

Incident Report for Life School

Resolved

All ClassLink services have been restored and are fully operational.

Components affected
Operational Sign in to ClassLink - Active Directory Integration
Operational Sign in to ClassLink - Google Integration
Operational Sign in to ClassLink - Azure Integration
Posted Oct 20, 2025 - 22:55 CDT

Identified

Classlink Team is monitoring
Posted Oct 20, 2025 - 08:37 CDT
This incident affected: AWS cloudFront, Canvas LMS, ClassLink Active Directory Integration, ClassLink Azure Integration, ClassLink Google Integration, ClassLink Roster Server, ClassLink Mobile apps, and ClassLink My Files.