Fiber Damaged LHSW and LMSW are down !!

Incident Report for Life School

Resolved

This incident has been resolved.
Posted Jun 23, 2025 - 14:52 CDT

Identified

Fiber Damaged LHSW and LMSW are down !! Spectrum is on location. This was an act of vandalism and is effecting 90 circuits in the area
Posted Jun 23, 2025 - 08:26 CDT
This incident affected: Internet Connectivity.